const regex = /^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?[^\\\/\\s]*\\.([^.\\s\\\/]*\\.[^.\\s\\\/]*)(?:$|\\\/.*)', 'gm')
const str = `http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);