#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b"
Local $sString = "Topic one ......... 30 Second Topic .......... 33" & @CRLF & _
"Third one ......... 3 Topic.with.dots .......... 33" & @CRLF & _
"One more line ......................... 27 last topic ...... 34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")