re = /(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b/i
str = 'Topic one ......... 30 Second Topic .......... 33
Third one ......... 3 Topic.with.dots .......... 33
One more line ......................... 27 last topic ...... 34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end