const regex = /(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[A-Z])(?:\\.[A-Z]+|[A-Z\\s]+)+\\b', 'gi')
const str = `Topic one ......... 30 Second Topic .......... 33
Third one ......... 3 Topic.with.dots .......... 33
One more line ......................... 27 last topic ...... 34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}