using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b";
string input = @"Topic one ......... 30 Second Topic .......... 33
Third one ......... 3 Topic.with.dots .......... 33
One more line ......................... 27 last topic ...... 34";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}