import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[A-Z])(?:\\.[A-Z]+|[A-Z\\s]+)+\\b";
final String string = "Topic one ......... 30 Second Topic .......... 33\n"
+ "Third one ......... 3 Topic.with.dots .......... 33\n"
+ "One more line ......................... 27 last topic ...... 34";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}