$re = '/(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b/i';
$str = 'Topic one ......... 30 Second Topic .......... 33
Third one ......... 3 Topic.with.dots .......... 33
One more line ......................... 27 last topic ...... 34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);