# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))/\2/g;t' <<< "ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u"