re = /(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))/
str = 'ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result