const regex = /(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ä|ö|ü)(?=[\\s\\S]*Dictionary:[\\s\\S]*\\1=([^\\s=:]+))', 'g')
const str = `ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);