$re = '/(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))/';
$str = 'ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;