#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))"
Local $sString = "ä into a" & @CRLF & _
"ö into o" & @CRLF & _
"ü into u" & @CRLF & _
"" & @CRLF & _
"Dictionary:" & @CRLF & _
"ä=a" & @CRLF & _
"ö=o" & @CRLF & _
"ü=u"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)