using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))";
string substitution = @"\2";
string input = @"ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}