import Foundation
let pattern = #"(ä|ö|ü)(?=[\s\S]*Dictionary:[\s\S]*\1=([^\s=:]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ä into a
ö into o
ü into u
Dictionary:
ä=a
ö=o
ü=u
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)