# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<)\b0+([1-9])/$1/g;t' <<< "10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
An amount of $10,001.02. Pretty expensive!
01.01.03"