$re = '/(?<)\b0+([1-9])/';
$str = '10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
An amount of $10,001.02. Pretty expensive!
01.01.03';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;