use strict;
my $str = '10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
An amount of $10,001.02. Pretty expensive!
01.01.03';
my $regex = qr/(?<)\b0+([1-9])/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";