import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<)\\b0+([1-9])";
final String string = "10/01/13 -> 10/1/13\n"
+ "10/10/13 -> no change\n"
+ "10/1/13 -> no change\n"
+ "01/10/13 -> 1/10/13\n"
+ "An amount of $10,001.02. Pretty expensive!\n"
+ "01.01.03";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}