const regex = /(?<)\b0+([1-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<)\\b0+([1-9])', 'g')
const str = `10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
An amount of \$10,001.02. Pretty expensive!
01.01.03`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);