#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<)\b0+([1-9])"
Local $sString = "10/01/13 -> 10/1/13" & @CRLF & _
"10/10/13 -> no change" & @CRLF & _
"10/1/13 -> no change" & @CRLF & _
"01/10/13 -> 1/10/13" & @CRLF & _
"An amount of $10,001.02. Pretty expensive!" & @CRLF & _
"01.01.03"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)