package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<)\b0+([1-9])`)
var str = `10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
An amount of $10,001.02. Pretty expensive!
01.01.03`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}