# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*=|%20/ /gm;t' <<< "url/Search/SearchResult?SearchText=FirstName%20Lastname"