re = /.*=|%20/m
str = 'url/Search/SearchResult?SearchText=FirstName%20Lastname'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result