use strict;
my $str = 'url/Search/SearchResult?SearchText=FirstName%20Lastname';
my $regex = qr/.*=|%20/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";