const regex = /.*=|%20/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*=|%20', 'gm')
const str = `url/Search/SearchResult?SearchText=FirstName%20Lastname`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);