const regex = /.*\\/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\\', '')
const str = `\\\\xxxxx\\xxxx\\xxx\\Companies\\test\\in\\Th FIle Test - Copy - Copy.mp4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);