import re
regex = re.compile(r".*\\")
test_str = "\\\\xxxxx\\xxxx\\xxx\\Companies\\test\\in\\Th FIle Test - Copy - Copy.mp4"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)