re = /.*\\/
str = '\\\\xxxxx\\xxxx\\xxx\\Companies\\test\\in\\Th FIle Test - Copy - Copy.mp4'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result