// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\\").unwrap();
let string = "\\\\xxxxx\\xxxx\\xxx\\Companies\\test\\in\\Th FIle Test - Copy - Copy.mp4";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}