use strict;
my $str = '\\\\xxxxx\\xxxx\\xxx\\Companies\\test\\in\\Th FIle Test - Copy - Copy.mp4';
my $regex = qr/.*\\/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";