#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$"
Local $sString = "AAAA1" & @CRLF & _
"AAA11" & @CRLF & _
"AA111AA" & @CRLF & _
"A1111" & @CRLF & _
"AAAAA1" & @CRLF & _
"AAAA1" & @CRLF & _
"AAAA1111" & @CRLF & _
"A1A1A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")