re = /^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$/m
str = 'AAAA1
AAA11
AA111AA
A1111
AAAAA1
AAAA1
AAAA1111
A1A1A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end