$re = '/^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$/m';
$str = 'AAAA1
AAA11
AA111AA
A1111
AAAAA1
AAAA1
AAAA1111
A1A1A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);