import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$";
final String string = "AAAA1\n"
+ "AAA11\n"
+ "AA111AA\n"
+ "A1111\n"
+ "AAAAA1\n"
+ "AAAA1\n"
+ "AAAA1111\n"
+ "A1A1A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}