const regex = /^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$', 'gm')
const str = `AAAA1
AAA11
AA111AA
A1111
AAAAA1
AAAA1
AAAA1111
A1A1A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}