using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$";
string input = @"AAAA1
AAA11
AA111AA
A1111
AAAAA1
AAAA1
AAAA1111
A1A1A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}