# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?is)<img(?(?=[^>]* alt="([^"]+)")).*?>/$1/;t' <<< "a <img src=\"./dir/file.png\" id=\"f\" alt=\"flying dogs\"> b"