use strict;
my $str = 'a <img src="./dir/file.png" id="f" alt="flying dogs"> b';
my $regex = qr~(?is)<img(?(?=[^>]* alt="([^"]+)")).*?>~p;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";