#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)<img(?(?=[^>]* alt="([^"]+)")).*?>"
Local $sString = "a <img src="./dir/file.png" id="f" alt="flying dogs"> b"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)