import re
regex = re.compile(r"(?is)<img(?(?=[^>]* alt=\"([^\"]+)\")).*?>")
test_str = "a <img src=\"./dir/file.png\" id=\"f\" alt=\"flying dogs\"> b"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)