re = /(?is)<img(?(?=[^>]* alt="([^"]+)")).*?>/
str = 'a <img src="./dir/file.png" id="f" alt="flying dogs"> b'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result