$re = '~(?is)<img(?(?=[^>]* alt="([^"]+)")).*?>~';
$str = 'a <img src="./dir/file.png" id="f" alt="flying dogs"> b';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;