#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$"
Local $sString = "bat,pat" & @CRLF & _
"bat,cat,pat " & @CRLF & _
"pat" & @CRLF & _
"bat" & @CRLF & _
"bat,cat" & @CRLF & _
"bat,mat,rat" & @CRLF & _
"cat,mat" & @CRLF & _
"mat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")