using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$";
string input = @"bat,pat
bat,cat,pat
pat
bat
bat,cat
bat,mat,rat
cat,mat
mat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}