// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$").unwrap();
let string = "bat,pat
bat,cat,pat
pat
bat
bat,cat
bat,mat,rat
cat,mat
mat";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}