$re = '/^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$/m';
$str = 'bat,pat
bat,cat,pat
pat
bat
bat,cat
bat,mat,rat
cat,mat
mat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);