package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$`)
var str = `bat,pat
bat,cat,pat
pat
bat
bat,cat
bat,mat,rat
cat,mat
mat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}