import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\\b)*$";
final String string = "bat,pat\n"
+ "bat,cat,pat \n"
+ "pat\n"
+ "bat\n"
+ "bat,cat\n"
+ "bat,mat,rat\n"
+ "cat,mat\n"
+ "mat";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}