re = /^(?:bat|cat|mat|rat)(?:,(?:bat|cat|mat|rat)\b)*$/m
str = 'bat,pat
bat,cat,pat
pat
bat
bat,cat
bat,mat,rat
cat,mat
mat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end