# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src=\"[^\"]+\"/src="image-replaced.png"/;t' <<< "<img src=\"image1.png\" class=\"image1\">
"